Kotlin plugin should be enabled before ‘kotlin-kapt’

We faced this issue when we updated Android Studio to the latest version 3.5 at the time of writing this tutorial. You would see the line “Kotlin plugin should be enabled before ‘kotlin-kapt’” in Run window when you run your Android Application.

Kotlin plugin should be enabled before ‘kotlin-kapt’
Kotlin plugin should be enabled before ‘kotlin-kapt’

We faced this issue when we updated Android Studio to the latest version 3.5 at the time of writing this tutorial.

You would see the line “Kotlin plugin should be enabled before ‘kotlin-kapt’” in Run window when you run your Android Application.

Kotlin plugin should be enabled before 'kotlin-kapt'

Solution

As the message says, all you have to do is you have to enable Kotlin plugin before kotlin-kapt in app\build.gradle.

The plugin contents of app\build.gradle file before solving this issue is shown below.

app\build.gradle

Now we will change the order of kotlin-kapt and kotlin-android with kotlin-android coming prior to kotlin-apt.

Now, when you run your application, you should not see this warning message.